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Introduction 
Pico Technology was established in 1991, and quickly became a leader in the field of PC Oscilloscopes, data 
loggers, and automotive diagnostic equipment. 

Pico Technology has always been recognized for providing innovative, cost-effective alternatives to traditional 
test equipment and data acquisition products. In doing so, it has made high-quality instrumentation 
affordable. 

The equipment 

Each PicoScope Automotive oscilloscope comes supplied with a base set of tools and components, allowing 
you to take the voltage and current measurements you need to perform a wide range of tests. 

The PicoScope unit itself takes the readings from the probes and clamps attached, and converts them into 
signals for your PC to display. It uses industry-standard BNC connections, enabling the use of a wide variety of 
accessories, and is connected to the PC or laptop by a USB cable, which it also uses to draw power. 

Automotive oscilloscopes 

A PicoScope (sometimes known as a lab scope) turns your laptop or desktop PC into a powerful diagnostic tool. 
Think of it as the X-ray machine of diagnostics, letting you see the changing signals inside wires. You can 
purchase a PicoScope on its own, but most people purchase one of our award-winning Automotive Diagnostics 
Kits. These money-saving kits contain everything you need – just add a PC.  

PicoScope Starter Kits are supplied in a cardboard packing box; other kits are supplied either in a tough carry 
case or with foam trays to fit a tool drawer.  

All tests done with the PicoScope involve very little mechanical intrusion, and remember, with every test you 
do with PicoScope you can: 

• Save the results you capture in a folder (like any PC file) and back them up into our Waveform Library. 
• Share the results with other users (providing a date- and time-stamped test procedure for future reference) 
• Replay the test results like a video 
• Accurately measure the time taken during each fluctuation 
• Compare results with previously saved tests 
• Measure even the fastest changes in the rise and fall of pressures 

You can read more about the company and our products on www.picoauto.com. 

This book 

This book gives an overview of the topics covered in Step 2, and moves on to cover topics such as: manual 
setup, viewing multiple signals, scaling, measuring, filtering, math channels, masks, alarms and more. It also 
incorporates the practical tests discussed during the training. 
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Overview of items covered in Step 2 

Voltage over time 

While we may prefer a more secure connection than multimeter probes, there is virtually no difference in the 
connection of these diagnostic tools. For our scope connection we use back-pinning probes or breakout leads 
to give a better connection, but in truth these are no more difficult to use. 

The user-friendly software makes it easy to capture, view and analyze waveforms. The waves are displayed in a 
signal view showing voltage over time. This simplifies the analysis and helps you find faults without invasive 
tests or any dismantling. 

Automotive guided tests 

The Automotive menu in PicoScope 6 contains over 150 guided tests and includes example waveforms and 
scope settings. These waveforms were captured using the Automotive Diagnostics Kit. 

An example waveform within the web help (guided test) topic shows how the signal should appear (the signal 
you see in PicoScope when you run the test will vary from one vehicle to the next). This will contain all the 
relevant settings to carry out the test, including correct timebase, voltage range, custom probe, and triggering. 

Rulers 

Measurements can be made using either rulers or automatic measurements. There are two rulers for time and 
two rulers per channel for voltage. The rulers can be used by moving the mouse over the ruler handles and 
dragging. You can move the time rulers left and right, and the voltage rulers up and down, at any time. 

The rotation rulers help measure the timing of a cyclic waveform. Instead of measuring relative to the trigger 
point, as time rulers do, rotation rulers measure relative to the start and end of a specified time interval. 
Measurements can be displayed in degrees, percent or a custom unit, as selected by the Ruler Settings box. 

Zoom 

There are several ways to zoom in on a signal, and to scroll around the zoomed waveform. When the 
waveform is zoomed in, the Zoom Overview window appears. You can resize this area by dragging the corners 
of the box, and move it by clicking and dragging within it. You can use the hand tool to move around a 
zoomed-in waveform, and to click and drag the main signal view. 
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Start-up Settings 

You can have your own predetermined start-up settings. These settings will be linked to the Home button in 
PicoScope, and will be the settings that appear when you open the software. 

First, let us tackle the question of why would you need this feature. Perhaps you use PicoScope regularly for a 
specific test that does not appear in our Automotive menu library. Your test may require several active 
channels with differing input ranges, a complicated trigger, and perhaps even an alarm function. To set up this 
test every time you want to capture signals could be time-consuming and would probably be quite frustrating. 

You use this feature by simply setting up the test as you normally would. But, instead of running the test, you 
choose File > Start-up Settings > Save User Default Settings. Now, each time you open PicoScope or click 
the Home button, your custom settings will be ready to go.  

Selecting Save Settings As stores all the current settings in pssettings format, allowing you to create a library 
of different setups. 

You can reset the Start-up Settings to default. Just choose File > Start-up Settings > Reset User Default 
Settings. 

 

Notes:  
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Manual set-up 

When you prepare to do a test, you may want to adjust the test settings manually to achieve the wanted 
result. To do this, you should adjust the key measurement points. 

Key measurement points 

Voltage 

With voltage we must remember that 1 V is equal to 1000 mV. The voltage setting is no different to your 
multimeter when it comes to selecting range. Just as you would turn the dial on your multimeter to the 
relevant scale, you just click on the Input Range drop-down menu to select the voltage range you require (for 
12 V systems this is typically ±20 V). This will now set your scope screen to display any voltage that falls 
between +20 V and –20 V. Each division on your vertical axis now has a value of 4 V (–20 to +20 V = 40 V range, 
divided by 10 divisions = 4 V per division). 

Time 

Selecting the time for a measurement is a feature you will not have considered when using your multimeter, as 
the value displayed on your meter screen would have been an average over a preset time. This is the 
fundamental problem with using a multimeter to measure voltages that change rapidly over time. 

As a general rule of thumb for measuring vehicle circuits, we use the 20/20 rule. This means ±20 V and 20 
ms/div. To select the relevant timebase, click on the Collection Time drop-down menu and select 20 ms/div. 

Each division on your horizontal grid will now have a value of 20 ms, meaning  your scope screen will display a 
timebase of 200 ms (200 ms timebase divided by  10 divisions = 20 ms per division). 

20 ms/div is chosen as the general timebase setting, to enable the scope to capture all events that take place 
during the four stroke cycle on one screen. This will make sure that you see everything from injection to 
ignition events. Two valuable points to remember here are:  The four stroke cycle takes 150 ms to complete at 
800 rpm, and 1 second is equal to 1000 milliseconds. 

You can view more detail of a single event by reducing the timebase. If you want to view more events with less 
detail you just have to increase the timebase. 
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Trigger 

The trigger feature will enable you to stabilize and display your waveform on screen, at precisely the right time 
during the signal capture. This training will give you an overview of the Triggering Toolbar with the Trigger 
mode, Trigger Source, Simple Edge, Trigger Threshold, and Pre-trigger options. 

When looking at voltage signals that change rapidly over time, they will appear to shift or jitter about your 
screen. This makes them very difficult to view and analyze in real time. To overcome this issue you can specify 
the conditions that must be met before the signal is displayed on screen. 

 

Triggering toolbar 

You can use the Triggering toolbar to make five key adjustments to the triggers. 

 
 

Trigger mode 

 
 
None: No trigger condition is set and PicoScope acquires waveforms repeatedly without waiting for a signal to 
trigger on. 

Auto: Forces PicoScope to wait for a trigger event before capturing the data. If, however, no trigger event 
occurs within a reasonable time, it captures the data anyway and it will keep on doing so until the capture is 
manually stopped. This is a great feature when using triggers for the first time as it will allow the scope to 
display a waveform even if you have set your trigger conditions outside the values for the signal being 
measured. 

Repeat: PicoScope waits indefinitely for a trigger event before capturing the data and will keep on doing so 
until the capture is manually stopped. If the trigger event never occurs, no data will be displayed. 

Single: PicoScope waits for a trigger event before capturing. 
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Trigger source 

This option defines where the trigger will come from, and varies between models. One thing common across 
all our products is that their input data channels can be used as triggers. 

 
 

Rising/falling edge trigger 

Trigger condition is the direction of trigger. Do you want the trigger to capture the signal when it is increasing 
(Rising Edge) or decreasing (Falling Edge)? 

These buttons control which side of the waveform you set the trigger on. For example, if you set a 1 V rising 
edge trigger, your PicoScope will only capture data if the signal increases from below 1 V to above 1 V. 

  
 

Trigger threshold 

The next trigger condition is the Threshold, the voltage level that has to be crossed in the direction specified in 
the previous step. Clicking the threshold arrows in the triggering toolbar will increase or decrease the voltage 
level required before the waveform is displayed on the screen. The selected threshold voltage is displayed 
adjacent to the threshold arrows, and a yellow diamond will appear on screen identifying where the threshold 
voltage has been set. 

Use this box to set the voltage of your trigger. In the rising/falling example above, the trigger threshold was set 
to 1 V. 
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Pre-trigger 

This is a very useful adjustment as it allows you to control how much you see of what happened before the 
trigger event.  

The following images show an injector voltage on a 500 μs/div timebase, giving a total of 5 ms across the 
screen.  

The first image shows a 20% pre-trigger, with 1 ms of data before the trigger event. Looking at the signal, you 
cannot see what happened to the waveform before this.  

The second image shows a 50% pre-trigger, with 2.5 ms before the trigger event, which makes it much clearer 
what the signal does. 

 
20% pre-trigger – 1 ms 

 

 
50% pre-trigger – 2.5 ms 
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Probe 

Selecting the right probe is essential as this informs the scope of the type 
of measurement you are about to take. The probe setting tells PicoScope 
what you use to take your measurement and how your data needs to be 
displayed. The x1 probe is often the standard for the majority of voltage 
measurements, and is conveniently set as the default probe selection. 
With the x1 probe selected, PicoScope sets the scale and unit values for a 
voltage measurement. However, if you select the 60 A current clamp from 
the probe drop-down menu, PicoScope will adjust the scale and unit 
values to display a current measurement correctly. 

 

 

 

 

Scaling 

Often when reviewing waveforms the valuable detail is hidden until we zoom, measure or filter. Zooming is an 
invaluable tool, but can add confusion when trying to keep track of the general perspective of the whole 
waveform (the zoom overview helps here). However, by using the scaling feature in PicoScope you can adjust 
the individual scales of each channel, revealing additional detail of each waveform while maintaining the 
original size of the overall capture. 

The first image shows Channel A secondary ignition waveform as captured with very little detail visible. 

The second image shows the same Channel A secondary ignition waveform after the scale has been increased 
6 times (x6.0), while the overall waveform view (screen size) remains unchanged. 

Note: As you adjust the scaling you may have to adjust the offset to keep your waveform on screen. The 
quickest way to do this is to drag the channel axis (the column of numbers to the left or right of the grid) up or 
down. 
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Measurements 
Clicking the Measurements button will reveal the Add Measurement options. Select the channel you wish to 
add a measurement to, the type of measurement, and the area of the waveform you would like to measure. 
Click OK after your selection to add the chosen measurement to your waveform as a numerical value. This will 
remove any guesswork and can be done before, during or after a capture. 

 

 

Automatic measurements 

You can add these in three different ways: From the Measurements menu, by right clicking on the screen, or 
by using the Measurements toolbar at the bottom of the display. 
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Whichever way you use, the Add Measurements box appears. 

 
 

Select the channel you want to take the measurements on by clicking on the first drop-down menu. Then you 
choose the type of measurement. Finally, choose which section of the graph you want to take the 
measurements from: This could be across the whole trace, between two rulers, or the cycle around one of the 
rulers. 

The measurements appear at the bottom of the screen. By default, the statistics are collected from the 
previous 20 captures. 

 

You can also adjust the font size by going to the Measurements menu and select Grid 
Font Size. 

 

 

Notes: 
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Aligning reference waveforms 
 

 
 

Noise reduction 
Filtering enables you to remove noise from a waveform that would otherwise prevent proper evaluation of the 
waveform. The term noise refers to areas of the waveform that display the effects of other circuits on the 
device that is measured. Interference is often a word used to describe noise as there may be times when the 
effects from the environment can cause noise on a waveform. 
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Typical signals obscured by noise 

• MAP sensor 

• Fuel Rail Pressure sensor 

• Oxygen sensor  

A typical signal susceptible to noise would be an oxygen sensor output signal, which has a very low voltage 
output (0.1 to 0.9 V) at a very low frequency (approx. 1 Hz). Now, imagine the environment of an engine bay, 
with high frequency, high voltage switching circuits in operation such as those responsible for ignition and 
injection events. The effects these circuits have on the weak oxygen sensor signal can render the acquired 
waveform unrecognizable. 

 
 

The Low Pass Filtering option with PicoScope removes high frequency noise from the waveform, to reveal only 
the relevant detail. Low pass filters high frequency noise, allowing only low frequencies to pass through to the 
scope display. 

Low pass filtering is only one example of the filtering techniques available. The new 4000 series scope has an 
in-built selectable 20 kHz hardware low pass filter available across all channels, and filters the signal before it 
reaches the display (pre-capture rather than post-capture). 

Notes: 



16 

Math Channels 
With math channels you do not have to worry about complicated math, as the software is preloaded with 
calculations that take away the fear and introduce the facility to simplify the data shown on screen.  

Math Channels can be applied to calculate: 

• Addition, subtraction, multiplication or division of any combination of channels 

• Min-Max, Average, or Inverted data  

• Duty Cycle 

• Frequency 

• RPM 

Math channels can be applied post-capture and numerous maths channels can be applied to any waveform. A 
typical and very useful math channel is A-B, which is the value of the input signal on Channel B subtracted from 
Channel A. 

Math channel A-B to calculate the volt drop. This is equivalent to taking two voltage measurements with 2 
voltmeters and subtracting one reading from the other. 

You can access the built-in math channels by selecting Tools > Math Channels and tick the box adjacent to A-B. 

Below is just one example of how the math channel A-B can assist the technician, by revealing the disruption 
to a CAN message as a result of component failure. Subtracting CAN LO from CAN HI reveals the physical layer 
of the message contained within the original capture.  

The math channel A-B perfectly demonstrates a new feature available with the brand new 4225 and 4425 
Automotive PicoScopes.  
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For example, a starter motor voltage-drop measurement with a voltmeter across the main supply cable, would 
traditionally be carried out by placing the positive test lead to battery positive and the negative test lead to the 
starter motor terminal 30 (main connection terminal). The starter motor would be energized and the value 
displayed on the voltmeter would give you the voltage drop across the starter cable. 

 

When using the previous 4000 Series scopes, each input shares a common ground. Connecting the ground 
cable of a test lead to battery negative (of any channel) would also ground the scope’s remaining BNC sockets. 
This is fine for all measurements made with reference to ground (0 V), but the test in question has the ground 
lead connected to +12 V. To carry out this test with a previous 4000 series scope, you need to use two 
channels: Channel A connected to battery positive terminal, Channel B connected to terminal 30 of the starter 
motor, and a test lead ground cable connected to the battery negative terminal. The engine is cranked and 2 
voltage readings are taken, one at the battery and one the starter motor. By using the math channel (A-B) we 
can calculate the voltage drop.  
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Masks 
Mask limit testing is a feature that tells you when a waveform or a spectrum goes outside a specified area, a 
mask, drawn on the scope view or spectrum view. PicoScope can draw the mask automatically by tracing a 
captured waveform, or you can draw it manually. Mask limit testing is useful for spotting intermittent errors 
during debugging, and for finding faulty units during production testing.  

Go to the main PicoScope menu and select Tools > Masks > Add Masks. This opens the Mask Library dialog. 
When you have selected, loaded or created a mask, the scope view will appear as follows: 

 
 

(A) Mask shows the allowed area (in white) and the disallowed area (in blue). Right-clicking the mask area and 
selecting the Edit Mask command takes you to the Edit Mask dialog. You can change the mask color with the 
Tools > Preferences > Colors dialog; add, remove and save masks using the Tools > Masks menu; and hide and 
display masks using the Views > Masks menu.  

(B) Failed waveforms. 
If the waveform enters the disallowed area, it is counted as a failure. The part of the waveform that caused the 
failure is highlighted, and persists on the display until the capture is restarted. 

(C) Measurements table. 
The number of failures since the start of the current scope run is shown in the Measurements table. You can 
clear the failure count by stopping and restarting the capture using the Start/Stop buttons. The measurements 
table can display other measurements at the same time as the mask failure count. 
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How to set up a Mask Limit Test: 

1. Display a stable waveform in a scope view. Adjust the voltage range and timebase so that the feature 
of interest fills most of the view. In this example, we are viewing a repetitive pulse such as one that 
might be found on a data bus. 

2. Select the Tools > Masks > Add Masks command. 
3. You should now be in the Mask Library dialog: Channel A is selected by default. You can change this if 

you want to apply the mask to a different channel. 
4. Click the Generate button to open the Generate Mask dialog. 
5. For now, accept the default settings and click Generate. Then click OK in the Mask Library dialog to 

return to the scope view. You will now have a mask drawn around the original waveform. 
6. PicoScope stops capturing when you enter the Mask Library dialog, so press the space bar to restart. 

If any captured waveform fails to fit inside the mask, the offending parts are drawn in a contrasting 
colour. The Measurements table shows the number of failures. 

7. Now you have a functioning mask limit test. 

Notes:  
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Alarms 
Alarms are actions that PicoScope can be programmed to execute when certain events occur. Use the 
Tools > Alarms command to open the Alarms dialog. The events that can trigger an alarm are:  

• Capture – when the oscilloscope has captured a complete waveform or a block of waveforms.  
• Buffers Full – when the waveform buffer becomes full.  
• Mask(s) Fail - when a waveform fails a mask limit test.  

The actions that PicoScope can execute are:  

• Beep  
• Play Sound  
• Stop Capture  
• Restart Capture  
• Run Executable  
• Save Current Buffer  
• Save All Buffers 

The alarm feature of PicoScope can be used to emit a beep (or any .wav file of your choice) when your 
waveform meets its trigger criteria. Good uses for this are intermittent problem vehicles which often run fine 
with the test equipment attached.  

The alarm feature allows you to walk away from your diagnostic setup;,safe in the knowledge that PicoScope 
will alert you with an audible warning when a fault occurs. 

To do this, you set your trigger as normal. Then, under Tools > Alarms, you enable the Beep option and then 
the Capture option (under Event). Confirm by clicking Apply and OK. 
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Extended COP usage 

While the COP and Signal probe is designed for COP measurements, any component subjected to a switching 
current can be detected using the signal probe. These include: 

• Solenoids 

• Injectors 

• Actuators 

• Motors 

• Coils 

• HT leads 

 

Notes: 
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Low Amps Clamp usage 
The low amps clamps are transducers that allow you to measure small electrical currents. 

The current clamps are ideal to use with PicoScope automotive oscilloscopes for measuring currents between 
10 mA and 60 A. This lets the PicoScope display current for fuel injectors and fuel pumps. 

The current clamps have two calibration settings, set by a slide switch on the handle of the probe. 

By using these clamps, there is no need to break into the circuit or disturb the isolation, as the opening jaws 
simply clamp around the current carrying conductor. No electrical contact is required. 

The current clamps have been designed for use with PicoScope oscilloscopes, and feature additional screening 
to reduce noise pickup. 

 

The low amps clamps can be used for: 

• Parasitic drain measurements 
• Petrol and diesel injector operation 
• Solenoid testing 
• Throttle motor functions 
• EGR actuator testing 
• Broadband O2 sensor testing (in conjunction with current multiplier)  
• High current consumption tests up to 60 amps (motor lock up test) 

Connecting the current clamp 

The current clamp features a BNC connector and can be plugged directly into a PicoScope. 

Once connected to the PicoScope, switch the current clamp on (green LED should light) and then clamp the 
jaws around the current-carrying conductor. 
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Parasitic drain 

Customer complaints surrounding flat batteries are common throughout the year with peaks during the winter 
season. Vehicles that fail to start after standing for a couple of days are often referred to as suffering from 
parasitic drain. 

We can traditionally evaluate both a battery and a starting and charging system very quickly indeed, but 
parasitic drain demands a prolonged test (30 minutes is common for a modern vehicle to shut down and move 
to sleep mode). For vehicles with a history of battery discharge, you may choose to monitor the parasitic drain 
overnight or even over a number of days.  

With a new battery installed, Pico Technology's current clamps have a continuous operating time from 14 to 
16 hours. For this reason, they are well suited to parasitic testing.  
 
A typical waveform  

The below is a typical waveform showing the shutdown of a modern vehicle into sleep mode. Our vehicle 
shutdown in around 6 minutes, but some modern vehicles can take between 30-45 minutes. 

1. We show battery voltage on channel A for reference. 
2.  We start PicoScope capturing data as the vehicle is first locked and the initial shutdown period starts 

(note that we have set the scope screen on an extended timebase 200s/per division). 
3. There is a step down in current as networks prepare for sleep. 
4. The vehicle enters Sleep mode. 
5.  Networks wake up after key fob activation. 

 We consider maximum permissible parasitic drain <80 mA. 
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How a current clamp operates in relation to the values we capture on our scope screen: 
 
The current flow through a conductor has the valuable side effect of producing a magnetic field about the 
conductor. By closing the jaws of our current clamp around the conductor, the magnetic field can be detected 
and converted into a voltage directly proportional to the strength of the magnetic field. The voltage is then 
sent to the scope and displayed on screen as a current value. Prior to connecting the clamp around the 
conductor a zero operation is carried out to ensure accurate display of current values and a true zero 
point reference. 

 

Notes: 
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Customization of PicoScope software 
You can customize several areas of the PicoScope software. You do this by going to the Tools menu and 
clicking Preferences. 

The Preferences allow you to set options for the PicoScope software: 

 
 

The Preferences options are split into tabs: 

 
 

 

General 

The Reset preferences button deletes any changes you have made and returns the preferences to the factory 
settings. 
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Waveform Buffer 

By default, the waveform buffer is set to 32, but you can change this to any number between 1 and 10 000. 
The actual number of waveforms may vary due to a number of factors: the device that is being used, whether 
the device is in block or streaming mode, the number of samples per waveform and the type of triggering 
used. 

 
 

Collection Time Units 

 
 

By default, the timebase of the scope is given in seconds per division. The total collection time, on the other 
hand, represents the time across all ten divisions of the screen. For example, a 10 ms/div timebase is 
equivalent to a total collection time of 100 ms. 

Measurement statistics 

When you make an automatic measurement, PicoScope 6 Automotive presents statistics recorded over a 
number of captures. This section of the Preferences allows you to control the number of captures you use. By 
default, it is set to 20, but you can increase it to 1000. 
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Power Management 

This control limits the speed at which PicoScope 
captures data from the scope. The other PicoScope 
settings, the type of scope and the speed of the 
computer will all affect whether this limit can 
actually be reached. PicoScope automatically selects 
the appropriate limit according to whether the 
computer is running on batteries or on mains (line) 
power. 

The capture rate is in captures per second. By 
default, it is set to 30 Captures per second. If other 
applications run too slowly on the PC whilst 
PicoScope is capturing, reduce the capture rate 
limit. When the computer is running on battery 
power, PicoScope imposes a performance limit to 
save the battery. You can increase this manually, 
but doing so will cause the battery power to drain 
very quickly. 

 

 

Sampling 

Slow Sampling Transition 

The oscilloscope has two modes of operation: block 
mode and streaming mode. In block mode, the 
device captures data to its own internal memory 
and then transfers it to the PC, so the trace appears 
on the screen once the buffer is complete. In 
streaming mode, the device continuously streams 
data to the PC, so the trace is drawn in real time. 

The Slow Sampling Transition control alters the 
timebase at which the device changes from block 
mode to streaming mode. You can choose from a 
number of different timebases, between 100 
ms/div and 500 s/div. By default, it is set to 200 
ms/div. 
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Slow Sampling Display 

This displays the previous buffer as the new 
one is being drawn. The image shown gives a 
clearer view of this. 

 
 

 

 

 

 

Colors 

Under this tab, you can change the colors of the 
traces, background, masks and a number of other 
aspects of the display. You can also adjust the line 
thickness of the traces and the grid. 

 
 

 

 

 

 
 

 

Keyboard shortcuts 

PicoScope 6 Automotive allows the use of shortcuts to 
the vast majority of its features. These can be accessed 
from the Keyboard tab of the Preferences. Highlighting 
an action allows you to enter the desired shortcut keys. 
You can use up to four keys for one shortcut, including 
up to three modifiers (Ctrl, Alt and Shift). Clicking the 
Assign button confirms entry, and upon clicking OK the 
new shortcut keys are ready to use. 
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 Regional & Language 

In this section, you can change the language in the 
software and select metric or U.S. units. This is easily 
done by selecting language or units and then clicking 
OK. You will then be prompted to restart the 
software. Clicking Yes will automatically exit the 
software and then start it up again with the language 
and the units you selected. 

 

 

 

 

 

 

Options 

The Advanced features settings let you to enable 
various features, adding buttons to the relevant 
toolbars. You can also choose whether the Trigger 
toolbar (Start/Stop etc.), which by default appears at 
the bottom of the waveform screen, appears at the 
top of the screen. 
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Recent files refer to the list of files that have been opened, which is shown in the File menu. You can modify 
this list to show up to 32 items. 

 

 

 

 

 

 

 

 

 

Printing 

When you print a waveform, some default 
text appears at the top and bottom of the 
page. You can modify this by editing the 
appropriate fields in this tab, and you can 
view the results by opening a print preview. 
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Updates 

While you can check for software updates at 
any time, you may prefer to set up automatic 
updates to make sure you always have the 
most up-to-date version of PicoScope 
Automotive. This menu also gives you the 
option to stay informed of software released 
under beta testing. 

 

 
 

 

 

 

 

Expansion of PicoScope 
There are many peripherals you can use to expand and improve your usage of PicoScope. 

PicoScope integrates seamlessly with Microsoft Windows®, which allows you to use the following features:  

• Multiple monitors of any size 
• Scope and scan data displayed together 
• PicoScope projected onto screens/walls 
• PicoScope audio via external speakers 
• Wireless mouse and keyboard support 
• Direct connection to internet 
• Easy top up of storage capacity 
• PicoScope uses generic PC peripherals 
• Direct & Wi-Fi printer connection 
• Economic expansion 

This makes it easier to use in different situations and environments, and gives you the ability to set up a 
feature-packed diagnostics station. 
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Notes: 
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Practical Demonstrations  
and Tests 
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Test 1: Injector voltage and current 

Although it is very valuable to simply use a current clamp to look at petrol injector waveforms, you will get a 
more detailed image of what the injector is doing by adding in a connection and view of the voltage. As you 
become more proficient in using PicoScope, you will find this method more useful for viewing injectors. 

To avoid damage to your scope, you may need to use an attenuator for this test.   

These instructions do not refer to an attenuator, as they are based on our PicoScope 4425 automotive scope. 

If you are using a previous PicoScope Automotive model, you will need either a 10:1 or 20:1 attenuator and 
will need to adjust the Probe settings for the relevant channel. You can find these settings by clicking on the 
Channel Options button and then: Probe > 10:1 Attenuator or Probe > 20:1 Attenuator. 

Connect: 

Plug the premium test lead into Channel A on the 
PicoScope and place a large black clip on the test lead with 
the black moulding (negative), and a back-pinning or 
multimeter probe onto the test lead with the red moulding 
(positive). Place the black clip onto the battery negative 
terminal and probe the switched-earth side of the injector 
with a back-pinning or multimeter probe. 

Alternatively a break out lead can be used as shown in our 
pictures, which makes the connection much easier. 

Connect the current clamp to Channel B on the PicoScope*. 
The current clamp should be placed onto the fuel injector's 
supply wire. 

Alternatively the TA012 breakout lead can be used, placing 
the low amps current clamp on either the blue or the 
yellow exposed cable section of the test lead. As there is no 
consistency as to which terminal carries the supply, it may 
be necessary to observe both waveforms and select the 
correct one. 

 

 
With the example waveform displayed on the screen you can hit the space bar to start looking at live readings. 
Snap the accelerator quickly from idle to full throttle and observe the waveform expanding under acceleration 
and (on some models) shutting off on over-run. The waveform is stabilized by using the falling voltage to 
trigger the oscilloscope. 

*If you have an old style current clamp with 4-mm banana plugs instead of a BNC connector, connect it to the 
PicoScope using the premium test lead. 
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Analyzing the waveform 

When you have captured your data, you should now 
have a 2-channel waveform that looks something 
like the illustration shown. This waveform lets you 
see the “correct” time that the injector is physically 
open. You can clearly see, from the current 
waveform (shown in red), that the waveform is 'split' 
into two easily defined areas.  
 
The detail is clear in the red waveform (channel B): 
The first part of the waveform is responsible for the 
electromagnetic force lifting the pintle; in this 
example the time is approximately 1.6 ms. This is 
often referred to as the solenoid reaction time. The 
remaining 2.5 ms is the actual time the injector is 
fully open. 

 
When the earth is removed, a voltage is induced into the injector and a spike approaching 85 volts is recorded. 

Record the results from your test in the following display:

 

Also use your rulers to measure the 2 key parts of the injector operations 

Time taken for the electromagnetic force lifting the pintle: _______ms 

Time injector is fully open: _______ms 
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Test 2: Camshaft & Crankshaft sync 

This is a key test using PicoScope, which gives you a powerful view of the working engine. The main purpose of 
the test is to evaluate these two waveforms together. This will allow you to look for any unwanted offset in 
timing between the two sensors, which again could indicate a slipped timing belt or a stretched timing chain.  

Due to the power of PicoScope, it is even possible to view the individual teeth on the flywheel by using the 
zoom function. 

Connect 

Channel A: Plug a BNC test lead into Channel A on the PicoScope. Fit a large black crocodile clip on the test 
lead with the black moulding (negative) and a back-pinning probe onto the test lead with the red moulding 
(positive). Place the black crocodile clip on the battery negative terminal, and probe the crankshaft position 
sensor's negative (or number 1) terminal with the back-pinning probe. 

Alternative connections (as our example shows) can be made using the TA012 breakout lead. Connect the BNC 
test lead directly to the two shrouded plugs on the breakout lead. If a smaller-than-anticipated waveform is 
shown, try reversing the connections. 

Typical connection to crankshaft is underneath the engine. 

Note that we use a breakout lead in our example, which really 
helps to capture a clean signal when working in awkward or hard 
to reach places. 
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Channel B: Plug a BNC test lead into Channel B on the PicoScope, place a large black crocodile clip on the test 
lead with the black moulding (negative) and a back-pinning probe onto the test lead with the red moulding 
(positive). Probe the outputs of the camshaft position sensor until the larger waveform is displayed. The 
smaller waveform will be the earth-return. 

This is a typical connection to the camshaft 
sensor. Alternatively, you can use the TA012 
two-pin test lead adapter. 

 

 

 

 

 

With the example waveform displayed on the screen you can now hit the space bar to start capturing live 
readings. 

 

In our example we can observe the output voltage from the AC-excited Crank Angle Sensor (shown in blue) 
and the inductive Camshaft Position Sensor trace (shown in red) simultaneously. The main reason for 
evaluating these two waveforms together is to look for any unwanted offset in timing between the two 
sensors, which can indicate a slipped timing belt. 

Using the Waveform Library 

The best way to be truly sure if you have a timing issue is to find a known good example for a vehicle matching 
the one you are working on. Our waveform library is available to all PicoScope users direct from our software 
menu. 
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Top Tip  

When you evaluate Cam and Crank signals, adjust the timebase (50 and 100 ms/div are ideal) to allow you 
to view more than one revolution of the engine. Use the powerful zoom function to see any details. 

Do this when you run the test and capture a screenshot showing a few revolutions. 

Initial capture over a longer timebase. 

Zoom in to view 1 revolution. You can now count the teeth on the flywheel (red signal). 
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To appreciate just how important this is, look at the situation below: 

The vehicle below was brought to a workshop complaining it hadn’t been running correctly since a recent 
repair at a different workshop unable to find the fault. The car had recently had a cam belt change. 

The fault code showed a problem with cam and crankshaft synchronization. PicoScope was used to view the 
operation of the cam and crankshaft together. 
 
Can you find the fault and explain what it might be? 
 

It is relatively easy to spot: there is a missing peak on channel A (crankshaft) at the beginning of the crankshaft 
revolution. 

Using the zoom tool, we can clearly see a missing peak in the waveform (highlighted below). 

 

This revealed a problem with a broken tooth on the flywheel, probably caused by a metal bar being used to 
stop the flywheel turning during recent work on the engine.  
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Crankshaft sensor Inductive (Good) + Camshaft sensor Hall effect (Bad) 

 

Camshaft sensor Hall effect (Good) + Camshaft sensor Hall effect (Bad) 

 

Camshaft sensor Hall Effect (Bad) + Crankshaft sensor Hall effect (Good)  
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Test 3: Fuel Pressure 

This is a simple yet valuable test for checking condition and efficiency of the fuel delivery system on a common 
rail diesel engine. By looking at the signal from the fuel rail pressure sensor, we can see how the system 
operates from start-up, through acceleration, and back down to idle. This is a good way to highlight any 
potential issues.  

Connect 

Plug the BNC test lead into Channel A of the scope. 
Connect a back-pinning probe to the positive 
(colored) plug on the test lead. Place a black 
crocodile clip on the negative (black) plug, and clip to 
a suitable earth connection in the engine bay. Probe 
the output wire of the sensor. 

 

 

 

 

If you have a specific breakout lead, it can really help 
you make the connection and get a crisp and clear 
signal from this component. 

 

 

 

 

To capture the data, you can either set your own preferred settings in PicoScope Automotive or use the guided 
test to set the parameters. Either way, you should make sure you have a nice long timebase to capture the 
data on a single screen. 

Run 
Start PicoScope and start the engine. When it is running with idle speed, you accelerate with WOT for 10 
seconds before you return the engine back to idle. This will give you a waveform similar to the illustration in 
this test. The following waveform illustrates a test of the fuel system on a common rail diesel engine, using the 
fuel rail pressure sensor. 
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Please note the following: 

The waveform starts on the left just after key-on, where the voltage is 0.5 V, corresponding to a pressure of 0 
bar. The sensor does this to provide a plausibility check: it should never normally read 0 V, so if it does, it has 
failed. When we start the engine, the voltage rises to about 1.3 V, which corresponds to about 280 bar, a 
common value at idle. During acceleration, the PCM immediately adds a shot of fuel to accelerate the engine 
to red-line, where it is held by the speed governor. The voltage then settles back to a lower value, about 
2.5 V, until we release the pedal back to idle, when it settles back to 1.3 V. 

The PCM varies the rail pressure between about 280 bar at idle and 1600 bar at full speed and load. The sensor 
is the feedback component in a control loop, and it informs the PCM how much pressure is in the rail. The PCM 
can then tell the pump to increase or decrease output accordingly. The PCM controls the pressure regulator or 
metering valve on the pump to control pump pressure. When you press down the pedal, the PCM immediately 
calculates how much fuel to give the engine based on speed, load, etc., and the internal calibration table. This 
fueling table is specific for that engine/vehicle combination. The sensor gives a continual feedback of rail 
pressure so that the PCM can make necessary pressure adjustments almost instantaneously. 

We can analyze the performance of the system by graphing the output of the sensor against time, during start, 
run, acceleration, full speed, and return to idle. We finally switch off and wait for the PCM to power down 
(normally around 10 seconds after key-off). To get a good waveform showing this, PicoScope should be set to a 
slow timebase in chart recorder mode. 

We then key-off and the engine stops. Note how the signal drops slowly back to 0.5 V over about 10 
seconds, before the PCM powers down near the right-hand end of the waveform. If the voltage drops very 
quickly to 0.5 V, the residual pressure is leaking away too quickly. This could indicate a problem with the 
system – for example a leaky injector, or a leak back through the pump.  

Remember that this test is done on an unloaded engine. On a fully loaded engine the centre section of the 
graph will rise well above 2.5 V. It will not, however, go above 4.5 V, as this represents about 1600 bar. 

Note: This is a plausibility check on the sensor: if it goes to 5 V (the sensor supply voltage), there could be a 
fault with the sensor. Always check technical data for specific vehicle values as these are a guide only. 
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Test 4: EGR valve 

PicoScope is a great way to test the performance of an Exhaust Gas Recirculation (EGR) valve, to ensure that 
the ECM is controlling this component correctly.  The purpose of the EGR valve is to recycle a small amount of 
the exhaust gas back into the induction process to reduce oxides of nitrogen (NOx). NOx is produced when 
combustion temperatures are high, often associated with lean burn engines. By recycling a small amount of 
exhaust gas, the combustion charge temperature is lowered and there is a reduction in NOx. The EGR solenoid 
is controlled by the Electronic Control Module (ECM) and also works in association with other devices that 
monitor the amount of gas that is recycled. This set up is often different for each manufacturer and there is 
normally a combination of vacuum and electrical solenoid valves. 

Connect 
After locating the EGR valve on your vehicle, start by plugging a BNC test lead into Channel A on the PicoScope, 
place a large black crocodile clip on the test lead with the black moulding (negative) and a back-pinning probe 
or multitester probe onto the test lead with the red moulding (positive). Place the large black crocodile clip 
onto the battery negative terminal and probe the exhaust gas recirculation solenoid valve's connections with 
the back-pinning probe or multitester probe as illustrated in the picture below. If you cannot reach the 
terminal or plug with a probe, you may be able to use a breakout box or lead if you have one available.  

Example waveform 

The valve will have two electrical 
connections:- (i) 12 V supply (ii) switched 
earth (note that there will be 12 V on 
both terminals until the right conditions 
are meet to switch the valve). The valve 
will also have a vacuum supply and a 
vacuum connection to the EGR valve.  
 
You should therefore see a pattern similar 
to this, clearly showing the EGR valve 
switching off and on at regular intervals. 
 
Remember the electronic solenoid is 
activated by switching the earth path to 
ground only under specified conditions; 
therefore you may wish or need to road 
test the vehicle in order to simulate the 
correct conditions. 
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Further information 

EGR operation takes place under very specific conditions. The ECM controls the earth path to the solenoid 
valve. The information the ECM requires for this operation is: engine temperature, vehicle speed, and engine 
load. Because this amount of precise data is required, it will only be possible to see the activation of the EGR 
solenoid valve while the vehicle is on a road test. 
 
The function of Exhaust Gas Recirculation (EGR) is to lower the oxides of nitrogen (NOx) under certain 
circumstances. As the internal combustion temperature rises, the nitrogen within the air/fuel mixture starts to 
oxidize causing NOx to be produced. While this burning is less than desired, it is inevitable as the air/fuel ratio 
is increased and a weaker mixture is ignited. 
 
The NOx output is at a maximum when the engine has reached its normal operating temperature and the 
vehicle is subjected to light throttle or light load conditions. 
 
The catalytic converter is designed to eradicate the majority of the NOx by neutralizing it when it comes into 
contact with the precious metal rhodium, but by reducing the NOx before it reaches the catalytic converter 
ensures even lower outputs. The EGR valve allows a small amount of the exhaust gases to 'bleed' back into the 
inlet manifold to lower the combustion temperature and reduce the chances of the nitrogen burning. The EGR 
valve is a small mechanical device that allows the passage of exhaust gas when it receives a vacuum supply.  
 
This supply is governed by a vacuum switch, which in turn is activated by a signal from the Electronic Control 
Module (ECM). NOx, like hydrocarbons, is measured in parts per million and the reading recorded in a 
workshop environment is significantly lower to that recorded when the vehicle is at cruise.  

The illustration shows a diagram of a typical EGR setup, 
with the EGR valve in the closed position.  

EGR taken to excess can affect combustion and increase 
hydrocarbons. It is therefore necessary to monitor the 
amount of exhaust gas that enters the inlet manifold. 
Different manufacturers perform this task in different ways, 
and some general examples of this are described below.  

 

 

Honda uses an ECM containing a programmed map. The map contains information on the correct amount of 
EGR according to factors such as: engine speed, road speed, temperature and load. Under the right conditions 
for EGR to take place, the ECM earths the path of the solenoid valve and this allows a vacuum source to 
operate the EGR valve. The EGR valve also includes a lift sensor, a similar device to a throttle potentiometer. It 
has a 5-volt supply, earth and variable signal back to the ECM depending on the position of the EGR valve. If 
the amount of exhaust gas passing through the valve exceeds the parameters in the ECM's map, the ECM shuts 
the solenoid valve by removing its earth path. This making and breaking, or 'pulsing', of the earth path allows 
fine adjustments to be made ensuring precise control of EGR. 
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GM, Vauxhall and Opel have a similar system, but the 
solenoid valve, lift sensor and the EGR valve are all one 
unit. Fault-finding is also made harder by the fact that 
EGR takes places inside the cylinder head through a 
passage connecting the exhaust and inlet manifolds. 

 

 

 

Ford, as always, have some interesting names and acronyms 
for the components within their EGR system. To start with, 
the control solenoid is referred to as an Electronic Vacuum 
Regulator (EVR), and their method of monitoring the amount 
of EGR is by a Differential Pressure Feedback Electronic 
System (DPFE). The DPFE sensor to the right measures the 
pressure inside the EGR tube either side of a restriction 
(venturi). This pressure difference is then converted into a 
voltage and sent to the ECM for reference. Again the ECM 
contains a map for the correct amount of EGR and if this 
differs the ECM adjusts the control of the EVR to trim the 
amount of gas passing to the inlet manifold. 

See the circuit diagrams for the Ford and GM/Vauxhall/Opel systems below. 
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Viewing multiple signals together – systems testing 

You should, by now, be well on your way to mastering data capture from components using a variety of 
probes. With this knowledge, you can move forward to the next step and make use of the full potential of the 
PicoScope. By capturing multiple signals you can start to understand not just how a component is working, but 
how its affects, and works alongside, other components. 

We have added two examples that are great starting points to gain an understanding of how systems work. 

There are of course many more important combinations of signals that can add real value to your diagnostics 
process, for example an introduction of pressure measurements with our WPS500X Pressure Transducer. 
Remember even at this level, the waveform library is a great source of information and shows practical ways of 
viewing components together. It is well worth taking the time to view some of these and learning to 
understand them. 

Note: We have not included information on how to connect to each component in these examples because, 
hopefully, by now you should be familiar with these connections. This information is, however, readily 
available in our guided tests. 

 

 

  



47 

Systems Test 1 – Petrol Systems 

Tools: 

• Laptop 
• PicoScope kit 
• Premium test leads with black battery clips 
• Back-pinning probes or breakout leads 
• 20 A / 60 A DC (low amps) current clamp 
• COP probe or HT extension lead if multiple ignition coil pack. 

Camshaft sensor, crankshaft sensor, injector, and ignition: 

 

This is arguably the most valuable overview of the electronics in an engine. 

Captured data: 

Channel A (Blue)  Crankshaft Sensor (Inductive) 

Channel B (Red)  Camshaft Sensor (Hall Effect)  

Channel C (Green) Injector 

Channel D (Yellow) Ignition 
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Waveform Notes: 

This is a complete engine cycle on a single screen – we know this by having two missing teeth present on the 
crankshaft position waveform. 

By viewing four sensors together we can see the crankshaft and camshaft operate together, with the extra 
added information from the injector and ignition. The view of the camshaft and crankshaft seen together is 
valuable information for engine timing problems, while the relationship between the injector and the ignition 
can indicate piston position. The piston position can then be proven with the WPS500X. 

All the relevant sensor information can be found in the guided tests. 

Overall, this capture enables confirmation of engine setup and operation. 

What to look out for with these signals:  

We are able to analyze the condition of the toothed rotor and also count the number of teeth if required – 
using this information and a Math channel can supply us with an RPM value. The peak to peak voltage should 
be noted as an indication of sensor air gap, assuming the circuit is electrically correct. 

Manipulating the throttle will show any wander between the two timing sensors, potentially showing a worn 
timing chain or a slack belt – this is made possible by using the injector as a trigger channel. 

Notes: 

Systems Test 2 – Diesel Systems 



49 

Tools: 

• Laptop 
• PicoScope kit 
• 5 premium test leads 
• Battery clips 
• Back-pinning probes or breakout leads 

Throttle position, diesel rail pressure, diesel pump, and air mass meter: 

 

Captured data:  

Channel A (Blue)  Air mass meter 

Channel B (Red)  Throttle position sensor 

Channel C (Green) Diesel rail pressure sensor 

Channel D (Yellow) Diesel pump 

 

Waveform Notes: 

Here we have the relationship between driver demand (Channel A), engine breathing (Channel B) and fuel 
control on the remaining two channels. 

Looking at four sensors together is a great way to see the operation of these sensors.  

We want to see immediate response in air flow from throttle request, along with rapid fuel pressure increase 
and control. 
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As the throttle opens, we want to see immediate response in air flow from throttle request, along with rapid 
fuel pressure increase and control. We can see how fast the sensors operate on WOT and if they meet the 
specific values shown in the guided tests. 

Equally on throttle closure, rail pressure reduces rapidly and is clearly linked to control valve circuit current. 

What to look out for with these signals: 

In this test we are looking for rapid response between all components. 

Slow rise in airflow relative to throttle could indicate several issues – blocked air filter or exhaust, faulty MAF 
sensor, or perhaps turbo control (requires another test). 

Notes: 
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